Information Services announces macOS Mojave support

Information Commons in the DePaul Library
(DePaul University/Jeff Carrion)
DePaul has certified Apple's newest upgrade to the operating system for Mac computers, macOS Catalina (10.15), as a supported version and users may begin upgrades to their computers at their convenience. 

Please note that Catalina may not be compatible with older pieces of software and will not work with 32-bit applications. Users are strongly encouraged to verify all important applications support macOS Catalina before upgrading. Instructions from Apple are available here.

If you are using OS X 10.12 or older, you must update your computer to a supported version as soon as you are able. If you have any questions or need assistance regarding this upgrade, please contact the Technology Support Center at (312) 362-8765.